java:无法访问org.springframework.boot.SpringApplication的解决方法

作者:极客李华 时间:2022-07-14 05:24:29 

报错信息如下:

java: 无法访问org.springframework.boot.SpringApplication
错误的类文件: /C:/Users/11848/.m2/repository/org/springframework/boot/spring-boot/3.0.0/spring-boot-3.0.0.jar!/org/springframework/boot/SpringApplication.class
类文件具有错误的版本 61.0, 应为 52.0
请删除该文件或确保该文件位于正确的类路径子目录中。

解决办法:

这个错误的原因是idea默认的spring-boot-starter-parent版本是3.0,改成2.7.6或者更低版本就可以了

java:无法访问org.springframework.boot.SpringApplication的解决方法

java:无法访问org.springframework.boot.SpringApplication的解决方法

合并集合

一共有 n 个数,编号是 1∼n,最开始每个数各自在一个集合中。

现在要进行 m 个操作,操作共有两种:

M a b,将编号为 a 和 b 的两个数所在的集合合并,如果两个数已经在同一个集合中,则忽略这个操作;

Q a b,询问编号为 a 和 b 的两个数是否在同一个集合中;

输入格式

第一行输入整数 n 和 m。

接下来 m 行,每行包含一个操作指令,指令为 M a b 或 Q a b 中的一种。

输出格式

对于每个询问指令 Q a b,都要输出一个结果,如果 a 和 b 在同一集合内,则输出 Yes,否则输出 No。

每个结果占一行。

数据范围

1≤n,m≤105

输入样例:

4 5
M 1 2
M 3 4
Q 1 2
Q 1 3
Q 3 4

输出样例:

Yes
No
Yes

提交代码

#include<iostream>
using namespace std;

const int N = 100010;
int n, m;
int p[N];

int find(int x)                 // 找到x的祖先节点
{
   if (p[x] != x) p[x] = find(p[x]);
   return p[x];
}

int main()
{
   scanf("%d %d", &n, &m);
   for (int i = 1; i <= n; ++i) p[i] = i;

while (m--)
   {
       char op;
       int a, b;
       scanf (" %c%d%d", &op, &a, &b);
       if (op == 'M') p[p[find(a)]] = find(b);        // 让a的祖先节点指向b的祖先节点
       else
       {
           if (find(a) == find(b)) puts("Yes");
           else puts("No");
       }
   }
   return 0;
}
import java.io.*;

public class Main
{
   static int N = 100010;
   static int n, m;
   static int [] p = new int [N];

static int find(int x)
   {
       if (p[x] != x) p[x] = find(p[x]);
       return p[x];
   }

public static void main(String[] args) throws IOException
   {
       BufferedReader reader = new BufferedReader(new InputStreamReader (System.in));  
       String [] str = reader.readLine().split(" ");
       n = Integer.parseInt(str[0]);
       m = Integer.parseInt(str[1]);

for (int i = 1; i <= n; ++ i) p[i] = i;
       while (m -- > 0)
       {
           String op;
           int a, b;
           str = reader.readLine().split(" ");
           op = str[0];
           a = Integer.parseInt(str[1]);
           b = Integer.parseInt(str[2]);
           if (op.equals("M")) p[find(a)] = find(b);
           else
           {
               if (find(a) == find(b)) System.out.println("Yes");
               else System.out.println("No");
           }
       }
   }
}

来源:https://blog.csdn.net/qq_51447496/article/details/128279192

标签:java,无法访问,org.springframework
0
投稿

猜你喜欢

  • .net的命名空间类库的简单介绍

    2023-01-19 17:56:27
  • C#数值转换-显式数值转换表(参考)

    2023-05-26 22:26:15
  • C#使用timer实现的简单闹钟程序

    2023-07-30 00:24:28
  • Android系统制作自定义签名的例子

    2023-02-02 05:10:04
  • C#如何动态创建lambda表达式

    2022-04-18 21:57:16
  • Android开发中记一个SwipeMenuListView侧滑删除错乱的Bug

    2021-08-02 04:24:21
  • Java Druid连接池与Apache的DBUtils使用教程

    2021-07-29 13:21:44
  • Spring Feign超时设置深入了解

    2022-01-17 10:39:06
  • 详解Java8与Runtime.getRuntime().availableProcessors()

    2023-01-04 18:17:06
  • springcloud-gateway整合jwt+jcasbin实现权限控制的详细过程

    2023-11-20 12:57:09
  • Android语音识别技术详解及实例代码

    2022-09-23 03:46:33
  • SpringCloud微服务架构实战之微服务治理功能的实现

    2023-07-20 09:06:38
  • 详解Android StrictMode严格模式的使用方法

    2023-09-14 17:03:39
  • 解决Springboot2.1.x配置Activiti7单独数据源问题

    2022-07-28 02:24:04
  • Android应用动态修改主题的方法示例

    2022-01-08 10:50:34
  • Android实现画板、写字板功能(附源码下载)

    2021-11-01 17:40:56
  • Spring Boot教程之利用ActiveMQ实现延迟消息

    2023-11-23 18:25:09
  • 浅谈mybatis中SQL语句给boolean类型赋值问题

    2023-01-19 15:15:42
  • C#多线程之线程池ThreadPool用法

    2021-07-21 06:28:40
  • 学习Java的9张思维导图

    2021-06-10 03:38:18
  • asp之家 软件编程 m.aspxhome.com